Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > In Car Electronics > XTRONS PA77DLRPL
Post Reply  Down to end
Page 10 of 11 <123 ... 91011>
Print this entire topic · 
Germplus1



Member Since: 19 Jul 2019
Location: London
Posts: 16

United Kingdom 2008 Freelander 2 TD4 SE Auto Baltic Blue

petero wrote:
If you look back a couple of pages in this thread I posted a picture of the most shunt with the cover still fitted next to the connector which previously plugged into the sat nav unit. remove the cover and plug the shunt onto the connector and it should work fine. Look here: https://www.freel2.com/forum/topic30709-90.html


Thank you. You are a legend Smile

Post #375499 20th Jul 2019 9:18 pm
View user's profile Send private message View poster's gallery Reply with quote
petero



Member Since: 27 Jul 2017
Location: Tamworth, Staffs
Posts: 19

United Kingdom 2007 Freelander 2 TD4 HSE Manual Sumatra Black

You're welcome, I'm glad I could help Smile

Post #375506 20th Jul 2019 10:02 pm
View user's profile Send private message View poster's gallery Reply with quote
Raywin



Member Since: 20 May 2016
Location: North Yorkshire
Posts: 34

England 

Just got round to installingh my unit in my 2010 FL2
Things were going as well as can be expected then I tried to plug the radio piggyback in and the plugs are different, any able to help[ here ? is there an adaptr or do I need a new piggyback lead,
would much appreciate any help with this

the grey plugs are on the piggyback lead, red one is my original radio plug


Post #375793 26th Jul 2019 4:09 pm
View user's profile Send private message View poster's gallery Reply with quote
Raywin



Member Since: 20 May 2016
Location: North Yorkshire
Posts: 34

England 

Well finaly sorted this out and in case it heps anyone else here is what I did


[img]http://www.freel2.com/gallery/albums/userpics/21230/Connection.pdf[/img]


I took an ignition + feed from the centre console cigarette lighter and used the light around the lighter to feed the night-time input which dims the Xtrons screen when the car lights are on.

All Ok now music player works when I put the radio to AUX but volume is so low I need to turn up to full volume on the radio, which can be a problem when you switch back to FM.
Added a centre speaker on the dash just for the sat nav

Post #376656 11th Aug 2019 1:02 pm
View user's profile Send private message View poster's gallery Reply with quote
Armalite5.56



Member Since: 29 May 2017
Location: Scotland
Posts: 13

United Kingdom 

So I have installed my new xtrons and so far not received the shunt but I have the original in the glove box so so far so good.

Next issue is the sound to the main unit. Currently only the little speaker is giving me any noise with aux set on the main unit. Even the aux in between the seats is no longer working and I think that is the main culprit in terms of the aux not working at all. Any ideas what I may have done wrong? I have tried connecting the audio out to the aux in on the xtron etc to no avail.

Post #377259 22nd Aug 2019 8:49 pm
View user's profile Send private message View poster's gallery Reply with quote
Armalite5.56



Member Since: 29 May 2017
Location: Scotland
Posts: 13

United Kingdom 

I managed to figure it out. Didn’t realise that xtron sent me two of the same connectors, one hardwired into the wiring loom and one loose so I plugged in the loose one and not the wiring loom audio out.

Now I just need to rejiggle the main headunit back into place is I can put it all back together.

Also does anyone know what the part number are for the clips as the very front of the top speaker cover as I managed to break some of them?

Post #377261 22nd Aug 2019 8:59 pm
View user's profile Send private message View poster's gallery Reply with quote
Armalite5.56



Member Since: 29 May 2017
Location: Scotland
Posts: 13

United Kingdom 

Anyone managed to get an app on their xtron that allows you to explore the music on an iPhone and not just play the set playlist? Like you can in the newer evoques etc without the android headunit. The A2dp app is ok but I’m a little annoyed I can’t explore other playlists, albums and artists from the xtron on my iPhone.

Post #377303 23rd Aug 2019 12:22 pm
View user's profile Send private message View poster's gallery Reply with quote
Armalite5.56



Member Since: 29 May 2017
Location: Scotland
Posts: 13

United Kingdom 



Very pleased with that

Post #377415 26th Aug 2019 5:42 pm
View user's profile Send private message View poster's gallery Reply with quote
Mike2165



Member Since: 09 Sep 2019
Location: Peterborough
Posts: 11

United Kingdom 2008 Freelander 2 TD4 GS Auto Lago Grey

So after trying to figure out what to do with the stereo, this thread comes up. Looks like I'm getting the Xtrons unit then. How good are they?

Post #378296 14th Sep 2019 7:40 am
View user's profile Send private message View poster's gallery Reply with quote
petero



Member Since: 27 Jul 2017
Location: Tamworth, Staffs
Posts: 19

United Kingdom 2007 Freelander 2 TD4 HSE Manual Sumatra Black

I've been very pleased with mine overall.

I have the DAB radio adapter fitted along with a reversing camera, a bluetooth ODB2 reader and music stored on a usb stick in the glovebox. The DAB sometimes locks up but always recovers when I restart it and I can use a variety of Android sat nav apps - mostly TomTom Go.

I fitted the WiFi antenna on an extension cable so it is located in the windscreen pillar which allows it to connect to the home WiFi from the driveway - great for downloading maps, updating apps etc.

I chose to leave my phone connect to the car's bluetooth as it allows the steering wheel phone controls to work but you can choose to connect the phone to the Xtrons - I didn't as I don't wish to read texts while I am driving!

If you want to listen to AM/FM radio or CDs the existing stereo still works fine but I rarely use either now.

Post #378501 18th Sep 2019 9:54 pm
View user's profile Send private message View poster's gallery Reply with quote
Mike2165



Member Since: 09 Sep 2019
Location: Peterborough
Posts: 11

United Kingdom 2008 Freelander 2 TD4 GS Auto Lago Grey

Thanks Petero. I have ordered the unit Very Happy Have you got the Andriod 8 or 9?

Post #378520 19th Sep 2019 8:45 am
View user's profile Send private message View poster's gallery Reply with quote
petero



Member Since: 27 Jul 2017
Location: Tamworth, Staffs
Posts: 19

United Kingdom 2007 Freelander 2 TD4 HSE Manual Sumatra Black

Mine is the Android 8, I think it has been in around 18 months now Thumbs Up

Post #378546 19th Sep 2019 9:35 pm
View user's profile Send private message View poster's gallery Reply with quote
Mike2165



Member Since: 09 Sep 2019
Location: Peterborough
Posts: 11

United Kingdom 2008 Freelander 2 TD4 GS Auto Lago Grey

Thinks Peter, ordered the Android 8 yesterday, should be here today. They have 20% off the 8 at the moment so got a bargain

Post #378553 20th Sep 2019 5:29 am
View user's profile Send private message View poster's gallery Reply with quote
Mike2165



Member Since: 09 Sep 2019
Location: Peterborough
Posts: 11

United Kingdom 2008 Freelander 2 TD4 GS Auto Lago Grey

So I'm fitting the xtrons unit on a cd400. Got the loom between the radio and car but nothing from the speakers, what am I not doing?

Post #378712 23rd Sep 2019 3:36 pm
View user's profile Send private message View poster's gallery Reply with quote
Mike2165



Member Since: 09 Sep 2019
Location: Peterborough
Posts: 11

United Kingdom 2008 Freelander 2 TD4 GS Auto Lago Grey

All sorted, great instructions Xtrons... Not

Post #378727 23rd Sep 2019 7:00 pm
View user's profile Send private message View poster's gallery Reply with quote
Post Reply  Back to top
Page 10 of 11 <123 ... 91011>
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2019 Futuranet Ltd & Martin Lewis


Switch to Mobile site