Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > General > Weird a/c related noise
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
CraigMate



Member Since: 26 Oct 2020
Location: Suffolk
Posts: 7

United Kingdom 2007 Freelander 2 i6 HSE Lux Auto Indus Silver
Weird a/c related noise

Just a quick one.
Having read all about everyone's problems with weird air-con related noises, I decided to have mine regassed. The garage diagnosed a blockage in the condenser. I've just picked her up, new condenser and glass, NOISE GONE!
So glad I did my research before I started replacing pulleys and tearing her apart.

Post #399051 28th Oct 2020 5:19 pm
View user's profile Send private message View poster's gallery Reply with quote
Wildyone



Member Since: 15 Jan 2018
Location: North Yorkshire
Posts: 17

United Kingdom 2009 Freelander 2 TD4_e HSE Manual Zermatt Silver

Hi

I’m having an issue with a strange metallic / fan / rattle when I have my AC on. It also has stated doing it with AC off and internal comfort fan on...but not often.

Did your original issue sound like this ?

If so will get a regas as well...just seams odd that this would fix it.

Thanks

Post #399649 10th Nov 2020 12:04 pm
View user's profile Send private message View poster's gallery Reply with quote
MotionInc



Member Since: 17 Jun 2019
Location: North America
Posts: 637

Canada 2008 LR2 i6 SE Auto Tambora Flame

I have a similar sound mostly when the vehicle is decelerating under final braking. The other time this happens is for a minute or less when I first turn the blower on. My assessment of the noise I am having is the blower motor fan bearing. Given the location of the fan and the requirement of a special tool to re & re, I ain't touching mine anytime soon if I have my way! Thumbs Up

Post #399650 10th Nov 2020 12:15 pm
View user's profile Send private message View poster's gallery Reply with quote
Wildyone



Member Since: 15 Jan 2018
Location: North Yorkshire
Posts: 17

United Kingdom 2009 Freelander 2 TD4_e HSE Manual Zermatt Silver

I would have said mine was fully AC related but then it did it with AC off and fan on. Fan off no sound at all.

Let’s see what OP says....lots of other forums and groups say it a regas. But before I spend £70/80 on it with a question.

Post #399652 10th Nov 2020 12:20 pm
View user's profile Send private message View poster's gallery Reply with quote
Wildyone



Member Since: 15 Jan 2018
Location: North Yorkshire
Posts: 17

United Kingdom 2009 Freelander 2 TD4_e HSE Manual Zermatt Silver

Was this the noise ?



Anyone else had this ?

Thanks

Post #399742 11th Nov 2020 3:13 pm
View user's profile Send private message View poster's gallery Reply with quote
gasman



Member Since: 02 May 2013
Location: Tyneside
Posts: 329

United Kingdom 2009 Freelander 2 TD4_e GS Manual Zermatt Silver

Sounds like the bearing in the compressor. Now at the point when I learn something new something old is lost out the other side !
Now retired so it doesn't matter anymore.

Post #400177 20th Nov 2020 3:12 pm
View user's profile Send private message View poster's gallery Reply with quote
Wildyone



Member Since: 15 Jan 2018
Location: North Yorkshire
Posts: 17

United Kingdom 2009 Freelander 2 TD4_e HSE Manual Zermatt Silver

Regas has sorted it had 120 in and should be 700 somthing... amazing really

Post #400204 21st Nov 2020 12:07 am
View user's profile Send private message View poster's gallery Reply with quote
woodwizzard



Member Since: 09 Nov 2020
Location: somerset
Posts: 11

United Kingdom 2009 Freelander 2 TD4 HSE Auto Nazca Sand

We have the same noise Wildyone. Will get a re-gas done and hope it goes away Thumbs Up

Post #400206 21st Nov 2020 6:50 am
View user's profile Send private message View poster's gallery Reply with quote
MotionInc



Member Since: 17 Jun 2019
Location: North America
Posts: 637

Canada 2008 LR2 i6 SE Auto Tambora Flame

I just listened to the vid posted, that's not the sound I have at all. Thumbs Up

Post #400216 21st Nov 2020 10:58 am
View user's profile Send private message View poster's gallery Reply with quote
Dave47



Member Since: 31 Aug 2014
Location: Sunny Margate Kent
Posts: 761

United Kingdom 2008 Freelander 2 TD4 SE Auto Izmir Blue

Wildyone wrote:
Was this the noise ?



Anyone else had this ?

Thanks


Sounds very simular to the sound I had,
Mine started to be noticable at around 2000RPM
seem to go on a regas, but after a couple of weeks came back (gas pressure all ok)
it seemed to worsen quickly and became more notiable at idle,
for me the answer was a new compressure, this was only the second one on a Freelander 2 my A/C guy has changed
in 19 years as an A/C specialist.
Dave I.A.M. F1rst Driver.
Gone 2003 Discovery TD5 Auto,
Gone 1986 Defender 90 Station Wagon
Gone 1984 Range Rover 3.5 Vogue Manual.
Gone 1970 Series 11A/3 SWB 3.5 V8 Hybrid
Gone 1964 Series 11A LWB Van
Gone 1966 Series 11A SWB Van
Gone 1964 Series 11A LWB Station Wagon,

Post #400220 21st Nov 2020 12:14 pm
View user's profile Send private message View poster's gallery Reply with quote
Wildyone



Member Since: 15 Jan 2018
Location: North Yorkshire
Posts: 17

United Kingdom 2009 Freelander 2 TD4_e HSE Manual Zermatt Silver

Hopefully mine will stay away..... Smile

Post #400226 21st Nov 2020 1:12 pm
View user's profile Send private message View poster's gallery Reply with quote
CraigMate



Member Since: 26 Oct 2020
Location: Suffolk
Posts: 7

United Kingdom 2007 Freelander 2 i6 HSE Lux Auto Indus Silver

Dave47 wrote:
Wildyone wrote:
Was this the noise ?



Anyone else had this ?

Thanks


Sounds very simular to the sound I had,
Mine started to be noticable at around 2000RPM
seem to go on a regas, but after a couple of weeks came back (gas pressure all ok)
it seemed to worsen quickly and became more notiable at idle,
for me the answer was a new compressure, this was only the second one on a Freelander 2 my A/C guy has changed
in 19 years as an A/C specialist.
Dave


That sounds remarkably similar to how mine sounded. Mine had the condenser replaced due to a partial blockage and has been good as gold since (touches wood).

Post #400370 25th Nov 2020 7:44 pm
View user's profile Send private message View poster's gallery Reply with quote
Dave47



Member Since: 31 Aug 2014
Location: Sunny Margate Kent
Posts: 761

United Kingdom 2008 Freelander 2 TD4 SE Auto Izmir Blue

I had already had the condensor replaced as it had corroded.
Dave I.A.M. F1rst Driver.
Gone 2003 Discovery TD5 Auto,
Gone 1986 Defender 90 Station Wagon
Gone 1984 Range Rover 3.5 Vogue Manual.
Gone 1970 Series 11A/3 SWB 3.5 V8 Hybrid
Gone 1964 Series 11A LWB Van
Gone 1966 Series 11A SWB Van
Gone 1964 Series 11A LWB Station Wagon,

Post #400404 26th Nov 2020 12:04 pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2020 Futuranet Ltd & Martin Lewis


Switch to Mobile site