Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > Maintenance & Modifications > MY13 LED brake light fault
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
Kot



Member Since: 04 Apr 2023
Location: In the ~Garden
Posts: 48

United Kingdom 2013 Freelander 2 SD4 HSE Auto Santorini Black
MY13 LED brake light fault

Daughters car, MOT was last week and it sailed through NO advisories.

Today, the OS led brake light has failed. All the other functions in that cluster are working. Can these brake leds be replaced? if so any one have a p/n or is it a complete new cluster £200+? Just seems odd all leds are out. Its MY13 and has original clusters fitted not an diy upgrade.

Somehow the passenger kicked off/dislodged the fuse box cover in the passenger footwell, is this just coincidence with the led failure? It happened the same morning, so seems suspicious.
Read somewhere that they are controlled by a module, not had chance to investigate further as daughter is out and about, but intend to DTC check maybe a reset will cure this fault.
Anyone had this issue.

Post #439299 11th Feb 2024 2:20 pm
View user's profile Send private message View poster's gallery Reply with quote
Nodge68



Member Since: 15 Jul 2020
Location: Newquay
Posts: 1702

United Kingdom 2009 Freelander 2 TD4 SE Manual Rimini Red

Check all the connections at the fuse, as many items are connected there, even if they're not actually fused.

The LED tail lamp assembly isn't repairable unless you have good electronics skills. 2009 Rimini Red SE TD4. My daily driver.
Gone. 2006 Tonga Green i6 HSE.

Post #439338 12th Feb 2024 3:09 pm
View user's profile Send private message View poster's gallery Reply with quote
Kot



Member Since: 04 Apr 2023
Location: In the ~Garden
Posts: 48

United Kingdom 2013 Freelander 2 SD4 HSE Auto Santorini Black

So finally got access to car and put the AP200 on it.
Reset 2 faults
P1703-00 intermittent "Brake switch out of self test range"
P0504-62 intermittent "Brake switch A/B correlation

All good both cleared, and OS brake light now works.
With out doubt now suspect it happened when the fuse cover was dislodged so checked cables all OK

One of life's mysteries Thumbs Up

Post #439379 13th Feb 2024 1:48 pm
View user's profile Send private message View poster's gallery Reply with quote
Redfox



Member Since: 07 Jan 2024
Location: Copenhagen
Posts: 48

Denmark 2007 Freelander 2 i6 SE Auto Izmir Blue

Great reply and good to know!
Thanks for sharing.
Kind regards,
Redfox.

Post #439410 14th Feb 2024 11:13 pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2024 Futuranet Ltd & Martin Lewis
Freel2.com RSS Feed - All Forums


Switch to Mobile site