Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > In Car Electronics > The backlight of the buttons and the display does not work.
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
minister



Member Since: 16 Nov 2022
Location: Novosibirsk
Posts: 6

Russia 2007 Freelander 2 i6 SE Auto Baltic Blue
The backlight of the buttons and the display does not work.

Hello. The backlight of the buttons and the display of the radio stopped working. The radio is working, the display is working. There is simply no backlight. Tell me if anyone had such a problem and was it possible to fix it ? Not to change to a new one, but to fix the old one.
2008 year, SE


Last edited by minister on 16th Nov 2022 9:51 am. Edited 4 times in total

Post #426899 16th Nov 2022 9:37 am
View user's profile Send private message View poster's gallery Reply with quote
minister



Member Since: 16 Nov 2022
Location: Novosibirsk
Posts: 6

Russia 2007 Freelander 2 i6 SE Auto Baltic Blue

Post #426900 16th Nov 2022 9:38 am
View user's profile Send private message View poster's gallery Reply with quote
Nodge68



Member Since: 15 Jul 2020
Location: Newquay
Posts: 902

United Kingdom 2009 Freelander 2 TD4 SE Manual Rimini Red

They're not bulbs but soldered in LEDs, which would need electronics skills to replace. They normally last the life of the vehicle, but there's always going to be exceptions I guess. 2009 Rimini Red SE, its getting there.

Post #426994 18th Nov 2022 6:55 pm
View user's profile Send private message View poster's gallery Reply with quote
minister



Member Since: 16 Nov 2022
Location: Novosibirsk
Posts: 6

Russia 2007 Freelander 2 i6 SE Auto Baltic Blue

The LEDs are whole, everything is shining. The reason is not in them. So I 'm looking for someone who had it and managed to fix it .

Post #427004 19th Nov 2022 1:10 am
View user's profile Send private message View poster's gallery Reply with quote
Badger51



Member Since: 01 Mar 2014
Location: Coffs Harbour
Posts: 828

Australia 

Have you looked to see if there is a PCB mounted fuse? That’s possibly a simple fix, if it has one & it’s blown. (Now Sold). 2008 Freelander 2 (Nazca Sand) SE TD4 Auto. Statutory write off & on WOVR for hail damage but still road legal.
171037Km as of 09/05/22
Superchips Bluefin Flash
Nanocom Evo II (also sold)

Post #427005 19th Nov 2022 2:02 am
View user's profile Send private message View poster's gallery Reply with quote
minister



Member Since: 16 Nov 2022
Location: Novosibirsk
Posts: 6

Russia 2007 Freelander 2 i6 SE Auto Baltic Blue

There is no fuse on the board. And when power is applied to the contacts, all the buttons are lit, and the display lights up. It is unclear where the problem is.

Post #427016 19th Nov 2022 11:29 am
View user's profile Send private message View poster's gallery Reply with quote
Badger51



Member Since: 01 Mar 2014
Location: Coffs Harbour
Posts: 828

Australia 

It sounds like a circuit diode has failed. Unless you have the skill & ability to trace it, you are out of luck. (Now Sold). 2008 Freelander 2 (Nazca Sand) SE TD4 Auto. Statutory write off & on WOVR for hail damage but still road legal.
171037Km as of 09/05/22
Superchips Bluefin Flash
Nanocom Evo II (also sold)

Post #427035 19th Nov 2022 9:44 pm
View user's profile Send private message View poster's gallery Reply with quote
Nodge68



Member Since: 15 Jul 2020
Location: Newquay
Posts: 902

United Kingdom 2009 Freelander 2 TD4 SE Manual Rimini Red

minister wrote:
The LEDs are whole, everything is shining. The reason is not in them. So I 'm looking for someone who had it and managed to fix it .

If all the LEDs are lighting, then surely it's working correctly.
Sorry not had that fault, and I'm not about to pull mine apart to look at the design of the back lighting. 2009 Rimini Red SE, its getting there.

Post #427059 20th Nov 2022 3:47 pm
View user's profile Send private message View poster's gallery Reply with quote
congoblue



Member Since: 28 Dec 2019
Location: Hull
Posts: 116

United Kingdom 2014 Freelander 2 TD4 SE Manual Loire Blue

I think the brightness of the button LEDs is controlled by the dashboard dimming and also whether headlights are on or not. Are other parts of the dashboard lit up?

Post #427071 21st Nov 2022 8:41 am
View user's profile Send private message View poster's gallery Reply with quote
minister



Member Since: 16 Nov 2022
Location: Novosibirsk
Posts: 6

Russia 2007 Freelander 2 i6 SE Auto Baltic Blue

Yes, the backlight works on all other devices and buttons. Brightness adjustment also works. Only the backlight on the tape recorder does not work. Many people have such a problem, but they have not found a solution yet. Here I'm trying to find out from you, maybe the problem was solved somehow.

Post #427145 23rd Nov 2022 10:37 am
View user's profile Send private message View poster's gallery Reply with quote
congoblue



Member Since: 28 Dec 2019
Location: Hull
Posts: 116

United Kingdom 2014 Freelander 2 TD4 SE Manual Loire Blue

There will be a transistor/FET which controls these LEDs, probably on the same PCB. As you have proved the LEDs work, this is most likely the problem. If you can trace back the LED tracks on the PCB you might be able to identify which transistor it is.

Post #427169 24th Nov 2022 9:03 am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2022 Futuranet Ltd & Martin Lewis
Freel2.com RSS Feed - All Forums


Switch to Mobile site