Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > United Kingdom > Wiper Switch Issue
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
Panda



Member Since: 25 Sep 2022
Location: Lockerbie
Posts: 2

United Kingdom 
Wiper Switch Issue

Hi. I'm hoping someone can steer me in the right direction with a wiper issue that cropped up today on my 07 fl2 se. When I switched my wipers to intermittent they didn't come on. However, the rear wiper did, but to really confuse the matter, the right hand indicator also came on. I also checked the wipers at normal speed and fast speed with the same outcome. It didn't matter if the stalk was in the forward or rear postion, the same thing happened. The only wipers that are working is the manual sweep by pressing down on the stalk - the washers front and rear are also working. I'm hoping it's just a stalk fault, but the right hand indicator coming on is confusing me.

Any guidance would be much appreciated.

Post #425570 25th Sep 2022 7:40 pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2022 Futuranet Ltd & Martin Lewis
Freel2.com RSS Feed - All Forums


Switch to Mobile site