Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > In Car Electronics > "Tesla Style" Android head units.
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
bnicho



Member Since: 24 Jun 2016
Location: Victoria
Posts: 57

Australia 2007 Freelander 2 TD4 GS Manual Sumatra Black
"Tesla Style" Android head units.

I took an eBay punt and bought a second-hand example of one of those Tesla screens.

The previous owner had it in a 2009 Freelander 2 auto with a low line head unit. I have a 2007 manual with a low line head unit so it should be compatible, same plugs etc.

When inserted into my car everything works except the reverse camera and reverse sensors. It seems like the canbus box provided with the head unit is not interpreting the signal correctly. If I reinstall the old head unit the reverse sensors do work and there is video signal on the camera.

Previous owner of the head unit confirms that it was working in his car including sensors and reverse camera. He removed it and reinstalled the old head unit before trading the car in.

I've been through every menu I can find and every setting I can think of and cannot crack the problem.

Any suggestions from the brains trust?

This is a video of my install journey:
https://youtu.be/yLtmRdxv5sM

Cheers,
Brett. Brett Nicholson
Greendale, Victoria
2007 Freelander 2 GS ex-UK now in Aus!
1973 Land Rover Series 3 88 ex-UK
1965 Morris Mini Traveller ex-UK
1966 Austin Mini Super-Deluxe ex-UK
1971 Morris Mini Moke
2013 Toyota Prado

Post #407297 4th May 2021 5:09 am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2021 Futuranet Ltd & Martin Lewis


Switch to Mobile site