Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > Tips & Tricks > Engine light (MIL) not working on LR2 MY2014
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
sobrinho



Member Since: 22 Jul 2019
Location: Brazil
Posts: 67

Brazil 2014 Freelander 2 SD4 HSE Auto Fuji White
Engine light (MIL) not working on LR2 MY2014

Hey,

My car just got back from the dealer for maintenance, and the dealer warned me that my engine light (MIL) is not working.

It simply does not turn on during the "pre-check" and turn off later but I have been asking around, and another owner mentioned that he has the same behavior as mine (are we both unlucky to have it not working?).

Even the dealer said that he already got a few without the engine light working in the pre-check but that he also saw at least one which had it working, meaning that something is not right.

Does it depend in the MY?

At least the owners manual says that is should turn on and off a few seconds later after starting the car.

This video is from my fellow (MY2013 SE SD4) and it looks exactly the same as mine (MY2014 HSE SD4):

Thanks!

Post #396326 30th Aug 2020 4:35 pm
View user's profile Send private message View poster's gallery Reply with quote
jules



Member Since: 13 Dec 2007
Location: The Wilds of Warwickshire
Posts: 2183

United Kingdom 2014 Freelander 2 SD4 SE Auto Firenze Red

Im assuming the MIL used to be present on the pre-check before it went for servicing.

In the UK unscrupulous people used to disable the MIL when selling a dodgy car. (take the bulb out or cover the light up etc) but a working MIL is now a requirement to pass the annual MOT test. Jules

Post #396340 30th Aug 2020 7:45 pm
View user's profile Send private message View poster's gallery Reply with quote
sobrinho



Member Since: 22 Jul 2019
Location: Brazil
Posts: 67

Brazil 2014 Freelander 2 SD4 HSE Auto Fuji White

That might be the case, mine was with the EGR clogged and disabled, I fitted a new one but the dealer noticed the MIL was missing.

Any idea how to check what has been done? Take the instrument panel off and check if the light is there/blocked?

Post #396391 31st Aug 2020 12:55 pm
View user's profile Send private message View poster's gallery Reply with quote
sobrinho



Member Since: 22 Jul 2019
Location: Brazil
Posts: 67

Brazil 2014 Freelander 2 SD4 HSE Auto Fuji White

FWIW, researching across another LR2 owners, they also don't have the MIL light, even the ones since brand new that didn't do any maintenance in the EGR/DPF yet.

Apparently we don't have it for all MY/engines.

See ya.

Post #396440 1st Sep 2020 1:14 pm
View user's profile Send private message View poster's gallery Reply with quote
SYFL2



Member Since: 16 Jun 2012
Location: Sheffield
Posts: 1875

2007 Freelander 2 TD4 HSE Auto Stornoway Grey

Post #396442 1st Sep 2020 1:31 pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2020 Futuranet Ltd & Martin Lewis


Switch to Mobile site