Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > General > FREELANDER 2 LOOSING POWER/ACCELERATION
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
Nathantrdc



Member Since: 09 Sep 2020
Location: West yorkshire
Posts: 19

England 2013 Freelander 2 TD4 Dynamic Auto Santorini Black
FREELANDER 2 LOOSING POWER/ACCELERATION

Hi im new to this forum and looking for some help, i have a 2013 Freelander 2 Dynamic Td4 Auto iv been having a problem with loosing power/acceleration. Basically the car runs fine for the first 15/20mins but as soon as the car warms up thats when the power drops and gets reallt sluggish setting off from a stand still it really struggles but will eventually get upto speed once i get past 30mph but as you can imagine pulling out from a junction on a hill once the power has gone is near impossible especially trying to get upto the speed of traffic. I have had the car in at an independent land rover ‘specialist’ who have plugged to car in for faults but it is showing no fault codes, they then tryed to manually diagnose which they couldnt, the turbo pipes have been changed aswell, then they checked the system for blockages which there was none then they did a terra clean which didnt help eather, all of this iv had to pay for and the car is no better off. Now they want to take the turbo and send it to a specialist to check it, they want to literally take everything apart at my expense which im not happy with so have picked it up as they have had it for 4 weeks and i have over £700 down with them and the car is no better off.

Please say someone has had this problem and knows the solution i would be great for any suggestions and advice.

thanks guys

Post #396842 10th Sep 2020 6:05 pm
View user's profile Send private message View poster's gallery Reply with quote
AJ918



Member Since: 26 Mar 2018
Location: North West
Posts: 166

United Kingdom 2014 Freelander 2 TD4 GS Auto Santorini Black

Hi

When was the fuel filter last changed? If not recent then I would start by replacing the fuel filter (use only genuine LR only, as some of the non genuine have had reported issues such as you have) restricted fuel supply can give the symptoms you described without showing up any DTC.

Post #396843 10th Sep 2020 6:13 pm
View user's profile Send private message View poster's gallery Reply with quote
Nathantrdc



Member Since: 09 Sep 2020
Location: West yorkshire
Posts: 19

England 2013 Freelander 2 TD4 Dynamic Auto Santorini Black

Thanks for the reply , had the a little over a year and hasnt been changed while i had it and it only had one owner before and dont know if they did. I have a genuine fuel filter been fit Tomorrow hopefully solves to issue. Someone mention the crank sensor CAS also would that be possible ?

Post #396844 10th Sep 2020 6:16 pm
View user's profile Send private message View poster's gallery Reply with quote
Denboy



Member Since: 24 Oct 2019
Location: Merseyside
Posts: 45

United Kingdom 2007 Freelander 2 TD4 S Auto Stornoway Grey

Crank sensor can cause the problems you have normally won't show a fault code but cheap to replace

Post #396867 11th Sep 2020 4:25 am
View user's profile Send private message View poster's gallery Reply with quote
Mikey



Member Since: 07 Jun 2008
Location: Dundee
Posts: 724

Scotland 2012 Freelander 2 SD4 HSE Auto Baltic Blue

Bet it had a cheap aftermarket fuel filter fitted Thumbs Up

They have an internal thermostat, and the cheap ones are known to stick shut, causing the fuel temperature to raise too high

Once above 80-ish degrees, it begins to restrict engine performance Thumbs Up

Post #396868 11th Sep 2020 5:07 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Nathantrdc



Member Since: 09 Sep 2020
Location: West yorkshire
Posts: 19

England 2013 Freelander 2 TD4 Dynamic Auto Santorini Black

Thanks pal im having a new one fit today genuine see how that goes

Post #396869 11th Sep 2020 5:49 am
View user's profile Send private message View poster's gallery Reply with quote
Nathantrdc



Member Since: 09 Sep 2020
Location: West yorkshire
Posts: 19

England 2013 Freelander 2 TD4 Dynamic Auto Santorini Black

New
I have changed the fuel filter on thursday and the car hasnt lost power as of yet done around 20miles with new genuine filter it had a non genuine filter in so hopefully all is well, fingers crossed
Thanks for the help guys really appreciated

Post #396937 12th Sep 2020 3:41 pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2021 Futuranet Ltd & Martin Lewis


Switch to Mobile site