Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > In Car Electronics > Trip Computer query
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
Deafender



Member Since: 09 Mar 2019
Location: Buckingham
Posts: 10

United Kingdom 2009 Freelander 2 TD4 HSE Auto Zermatt Silver
Trip Computer query

I like this forum - I've been a member for just one week and managed to look up most of the little niggles or queries I have relating to my FL2... there's just one I haven't found any reference to (which doesn't automatically mean it's not there... Embarassed )

Just before my engine malady a month ago, I found that suddenly the trip computer wasn't operating whereas it had been fine. Post-engine transplant it still doesn't, so the mark one disconnect-the-battery solution hasn't restored it.

I don't think it's the display itself - messages like "Driver's Door Open" and so-on still show up on the screen, but the "i" button the end of the indicator stalk isn't producing anything on the screen itself, and there's no trip computer data at all showing.

It's either the switch itself or there is, I assume, some kind of module somewhere on the vehicle that handles that data... and that it needs either a re-program or replacement. Either way I'd like to retrieve the functionality, provided I don't have to sell my house to pay for it!!

Has anyone experienced this issue or have any idea how I can even get the fault located, followed hopefully by getting it fixed somehow somewhere. I'm fine changing oil/oil filters and recently changed both headlamp bulbs, but electronics and I stay firmly apart and always will... Very Happy

Cheers! 2009 Freelander 2 HSE, just had a new engine fitted so good for another 200K miles at least!

Post #368347 13th Mar 2019 4:48 pm
View user's profile Send private message View poster's gallery Reply with quote
JulesK



Member Since: 07 Dec 2014
Location: Ceredigion.
Posts: 1021

Wales 2014 Freelander 2 TD4 HSE Auto Firenze Red

Same here with electronic stuff Shocked sorry



Sheep If it wasn't so bad it'd be funny.

🐑

Freelander 2 GS 2013..... Gone.
Freelander 2 HSE auto 2014 ( Florrie ) ..... Try again.

Post #368351 13th Mar 2019 5:45 pm
View user's profile Send private message View poster's gallery Reply with quote
Vanny



Member Since: 06 Dec 2015
Location: Staffs
Posts: 204

United Kingdom 2013 Freelander 2 SD4 XS Auto Santorini Black

One of the information "options" as you scroll through is to simply show nothing, and the fact that the information button on the end of the stalk doesn't seem to be working makes me think the display is fine, but there is something wrong with the stalk.
Do all the other functions on the stalks work?

Post #368355 13th Mar 2019 8:06 pm
View user's profile Send private message View poster's gallery Reply with quote
Deafender



Member Since: 09 Mar 2019
Location: Buckingham
Posts: 10

United Kingdom 2009 Freelander 2 TD4 HSE Auto Zermatt Silver

Hello Vanny,

Yes everything else via the stalk is working fine... indicators, headlamp flash etc... same on the other side for the wipers etc... 2009 Freelander 2 HSE, just had a new engine fitted so good for another 200K miles at least!

Post #368374 13th Mar 2019 10:54 pm
View user's profile Send private message View poster's gallery Reply with quote
Badger51



Member Since: 01 Mar 2014
Location: Coffs Harbour
Posts: 266

Australia 2008 Freelander 2 TD4 SE Auto Nazca Sand

It would only take a bad contact in the push button circuit to stop it working, as Vanny has already suggested. It would be the first thing to check out imho.

Nick 2008 Freelander 2 (Nazca Sand) SE TD4
123000 Km as of 05/18
Superchips Bluefin Flash
Nanocom Evo II

Post #368376 13th Mar 2019 11:00 pm
View user's profile Send private message View poster's gallery Reply with quote
Deafender



Member Since: 09 Mar 2019
Location: Buckingham
Posts: 10

United Kingdom 2009 Freelander 2 TD4 HSE Auto Zermatt Silver

Yep, makes sense... It doesn’t look like the button part itself can dismantle... well, everything will dismantle once, but I wouldn’t want to break it in the process... Smile

It’s not affecting the car overall so it’s one to add for the auto electrician... I’ll be getting a towbar added soon and also adding a hardwired dash cam, an insurance requirement when I renew in April.

I’m actually really interested to see how the car is doing on fuel economy with the combination of brand new tyres and new engine... just a little piece of comfort for the large hole these made in my finances.... Cool 2009 Freelander 2 HSE, just had a new engine fitted so good for another 200K miles at least!

Post #368382 14th Mar 2019 6:36 am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2019 Futuranet Ltd & Martin Lewis