Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > Maintenance & Modifications > Reduced engine performance B100A
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
JonMs



Member Since: 25 May 2018
Location: Ilkley
Posts: 7

United Kingdom 2011 Freelander 2 SD4 HSE Auto Santorini Black
Reduced engine performance B100A

So............I bought my FL SD4 a few weeks ago and have been happy with it, pulls like a train and beautiful to drive. In the last week however it had developed a really annoying fault which manifests as follows: Car drives fine with no problems, stop car, re-start car and "Reduced engine performance" is triggered".

The fault code that is triggered is "B100A-15 (6C) Fuel pump authorisation - General electrical failure - circuit short to battery or open".
Now, the reduced performance will not re-set on it's own, I have to clear the fault code for this to happen after which the car is fine again............ until i next stop and start again. It doesn't happen every time, about one in three key starts.

I have read all the threads here on REP, have checked the intercooler hoses for leaks, the fuel filter is nearly new. I've run out of ideas! Please help!

Post #352387 28th Jun 2018 12:52 pm
View user's profile Send private message View poster's gallery Reply with quote
JonMs



Member Since: 25 May 2018
Location: Ilkley
Posts: 7

United Kingdom 2011 Freelander 2 SD4 HSE Auto Santorini Black

I still have this problem. It seems that to trigger the fault I don't need to start the engine, switching on the ignition and letting the system do it's system check is enough. It seems to be annoyingly intermittent Big Cry .

Anyone seen this before?

Post #352541 1st Jul 2018 4:39 pm
View user's profile Send private message View poster's gallery Reply with quote
Greybeard



Member Since: 10 Aug 2010
Location: E Sussex
Posts: 123

United Kingdom 2008 Freelander 2 TD4 GS Auto Zermatt Silver

Sorry, never heard of this sort of fault. However bad earths and poor battery can throw all sorts of weird results. Do you have the additional earth strap fitted? If not, that is what I would do first.

Post #352552 1st Jul 2018 6:28 pm
View user's profile Send private message View poster's gallery Reply with quote
I Like Chips



Member Since: 25 Jun 2017
Location: Cheltenham
Posts: 236

United Kingdom 2011 Freelander 2 SD4 HSE Auto Indus Silver

Had the same fault since I bought the car a year ago but the it runs fine. I been trying to discover a cure.

An independant checked it out and told me that some cars throw the fault. They could have it in for a couple of days check it over but there is no guarantee it will be fixed. Just have to live with it until it makes the car undrivable.

Post #352568 1st Jul 2018 8:44 pm
View user's profile Send private message View poster's gallery Reply with quote
JonMs



Member Since: 25 May 2018
Location: Ilkley
Posts: 7

United Kingdom 2011 Freelander 2 SD4 HSE Auto Santorini Black

In this case the fault triggers Reduced Engine Performance which i can only remove with my code reader so I'll have to find a solution. I've ordered a second earth strap and ill try that first as suggested. Thanks for your advice.

Post #352578 2nd Jul 2018 7:45 am
View user's profile Send private message View poster's gallery Reply with quote
JonMs



Member Since: 25 May 2018
Location: Ilkley
Posts: 7

United Kingdom 2011 Freelander 2 SD4 HSE Auto Santorini Black

Sorted. It was a faulty DPF pressure sensor. Diagnosed by analysing live data from the sensor.

Post #352986 9th Jul 2018 5:04 pm
View user's profile Send private message View poster's gallery Reply with quote
I Like Chips



Member Since: 25 Jun 2017
Location: Cheltenham
Posts: 236

United Kingdom 2011 Freelander 2 SD4 HSE Auto Indus Silver

Well done but are you still pulling the B100A-15 (6C) Fuel pump authorisation - General electrical failure - circuit short to battery or open Error Code

Post #352988 9th Jul 2018 5:42 pm
View user's profile Send private message View poster's gallery Reply with quote
JonMs



Member Since: 25 May 2018
Location: Ilkley
Posts: 7

United Kingdom 2011 Freelander 2 SD4 HSE Auto Santorini Black

Just checked and yes, the same fault code now keeps returning even though the car is now fixed and driving fine.

Post #353109 11th Jul 2018 11:32 am
View user's profile Send private message View poster's gallery Reply with quote
I Like Chips



Member Since: 25 Jun 2017
Location: Cheltenham
Posts: 236

United Kingdom 2011 Freelander 2 SD4 HSE Auto Indus Silver

Thanks for the reply. It's as I suspected.

Post #353114 11th Jul 2018 12:53 pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2018 Futuranet Ltd & Martin Lewis