Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > In Car Electronics > XTRONS PA77DLRPL
Post Reply  Down to end
Page 4 of 5 <12345>
Print this entire topic · 
NightDragon



Member Since: 23 Jun 2018
Location: Vienna
Posts: 2

Austria 
Xtrons PB78DLRPL / Connectors & wireing?

Hi all,

I'm new to the Freelander and new to this forum. Put of course, not a full week after we bought the car I already ordered the PB78DLRPL. Now i sturrfle to connect and would be really happy to get a hint from you guys.

Can anyone tell me the counterpart of the following connectors?


Do i have to remove the climatic controls too?

BR & Thanks,

Nighty

Post #352027 23rd Jun 2018 7:15 am
View user's profile Send private message View poster's gallery Reply with quote
NightDragon



Member Since: 23 Jun 2018
Location: Vienna
Posts: 2

Austria 

Just foudn it. It's in the back of the middle console between the front seats...

Post #352049 23rd Jun 2018 3:58 pm
View user's profile Send private message View poster's gallery Reply with quote
Grue



Member Since: 29 Apr 2018
Location: New Zealand
Posts: 34

New Zealand 2007 Freelander 2 TD4 SE Auto Sumatra Black

How's everyone doing with their installs? Still happy (barring the steering wheel controls...) after some time with them?

Post #352569 1st Jul 2018 8:46 pm
View user's profile Send private message View poster's gallery Reply with quote
dazxman24



Member Since: 26 Apr 2018
Location: Bridgend
Posts: 4

United Kingdom 2012 Freelander 2 TD4 GS Manual Orkney Grey

I've just installed a head unit into my 2012 GS and got it working, but i have the same sound output problem. I'll try the additional cables tonight (as suggested by Trekker1972) i didn't think that oyu had to install all of the cables if they weren't being used, but it does make sense. fingers crossed.

Post #352980 9th Jul 2018 3:09 pm
View user's profile Send private message View poster's gallery Reply with quote
johnny_22_83



Member Since: 05 Dec 2010
Location: bucuresti
Posts: 180

Romania 2008 Freelander 2 TD4 SE Auto Sumatra Black

The grey connector fits to the one behind the radio unit. If you remove the hole unit, not just the front part, you will see that it has a grey connector. So the Xtrons grey connector comes between the car's grey connector and the radio unit.
This way you power the Xtrons and in the same time have access to car's speakers. But, in order to complete the audio connection you have to put together the white/red RCA connectors that came with Xtrons (you will see that there are 4 RCA audio connectors - 2 white and 2 red). Connect white to white and red to red, of course, and you'll see that the radio unit AUX option will give you audio access to Xtrons.

Post #353085 11th Jul 2018 7:48 am
View user's profile Send private message View poster's gallery Reply with quote
johnny_22_83



Member Since: 05 Dec 2010
Location: bucuresti
Posts: 180

Romania 2008 Freelander 2 TD4 SE Auto Sumatra Black

The grey connector fits to the one behind the radio unit. If you remove the hole unit, not just the front part, you will see that it has a grey connector. So the Xtrons grey connector comes between the car's grey connector and the radio unit.
This way you power the Xtrons and in the same time have access to car's speakers. But, in order to complete the audio connection you have to put together the white/red RCA connectors that came with Xtrons (you will see that there are 4 RCA audio connectors - 2 white and 2 red). Connect white to white and red to red, of course, and you'll see that the radio unit AUX option will give you audio access to Xtrons.

Post #353086 11th Jul 2018 7:49 am
View user's profile Send private message View poster's gallery Reply with quote
Scottc3000



Member Since: 13 Jul 2018
Location: Somerset
Posts: 9

United Kingdom 2007 Freelander 2 TD4 HSE Auto Firenze Red

I've just gone for android 8 version. Installation is going fairly well :/

1. I bought a 4g dongle for internet connection. Plugged it into one of the usb inputs but no joy there. Maybe I will just tether off my phone

2. I cant get audio out. I plugged the rca plugs and sockets together as suggested bur no sound from aux in radio. How did everybody disconnect the silly little hanging speaker? I just disconnected the join socket in the lead. Am I missing something?

3. Not sure how to connect reversing camera up. Manual for the camera says that if you wire it into the reversing light on FL it will just automatically come in when you go into reverse, is this true?. Any clues on where to wire the small red wires on the camera cable

Sigh, one step at a time Smile

Post #353558 18th Jul 2018 2:55 pm
View user's profile Send private message View poster's gallery Reply with quote
johnny_22_83



Member Since: 05 Dec 2010
Location: bucuresti
Posts: 180

Romania 2008 Freelander 2 TD4 SE Auto Sumatra Black

1. I use one like this https://consumer.huawei.com/en/mobile-broadband/e8372/ pluged into an usb engine powered slot and every time I start the car I have a wifi network to connect all my devices, including the Xtrons.

2. I’ve also disconnected the join socket in the lead. At first I thought it doesn’t work but guess what....the xtrons volume was to low Whistle Maybe you have the same problem.

3. I also have a bit of an issue with the camera. First, I’ve tried to see if it works. I’ve connected the video RCA from the rear camera to the “back video in” RCA connector from xtrons and a lead from the reverse light to the “reverse in” lead from the xtrons and it did work. But, when I finaly managed to install the xtrons to it’s place......no more video from the back camera. I have to figure it out and see way it doesn’t work anymore but I saw that it automatically switches to reverse camera when it gets the power signal from the reverse light.

Post #353596 19th Jul 2018 1:20 pm
View user's profile Send private message View poster's gallery Reply with quote
Scottc3000



Member Since: 13 Jul 2018
Location: Somerset
Posts: 9

United Kingdom 2007 Freelander 2 TD4 HSE Auto Firenze Red

Thanks. This is all a big help.
I have similar dongle, I had plugged it into the usb from the xtrons and thought it would add a network like s phone does but I think I should try it like you and treat it as a Wi-Fi hotspot.

I have turned up volume on xtrons but no sound.

I will try some tests with the camera and let you know how i get on. Did you use the reverse light as the power source or just connect the little red wire of the video cable to it?

Post #353608 19th Jul 2018 3:55 pm
View user's profile Send private message View poster's gallery Reply with quote
johnny_22_83



Member Since: 05 Dec 2010
Location: bucuresti
Posts: 180

Romania 2008 Freelander 2 TD4 SE Auto Sumatra Black

My video cable does not have that small wire connected to one of the RCA connectors. It’s a simple RCA to RCA cable. And I have a separate wire that comes from the reverse light.

Post #353671 20th Jul 2018 10:07 am
View user's profile Send private message View poster's gallery Reply with quote
dazxman24



Member Since: 26 Apr 2018
Location: Bridgend
Posts: 4

United Kingdom 2012 Freelander 2 TD4 GS Manual Orkney Grey

got mine all working, simple fault, i forgot to connect one of the standard cables. very happy now

Post #353751 21st Jul 2018 12:55 pm
View user's profile Send private message View poster's gallery Reply with quote
johnny_22_83



Member Since: 05 Dec 2010
Location: bucuresti
Posts: 180

Romania 2008 Freelander 2 TD4 SE Auto Sumatra Black

I’ve also managed to fix the reverse camera. All the cables were connected as they should be but it seems that I had a blown fuse (F11 - reverse light). I think I’m to blame for that Rolling Eyes (probably it happened when I first tested the sistem). Since then I’ve been driving without reverse light (as our beloved car doesn’t warn you when you have a non functioning light).
Now I’m hoping to send video signal to headrest monitors. That’s my final frontier when it comes to xtrons unit.

Post #353755 21st Jul 2018 3:58 pm
View user's profile Send private message View poster's gallery Reply with quote
Steven.T



Member Since: 08 Nov 2015
Location: Stockton-On-Tees
Posts: 208

United Kingdom 2009 Freelander 2 TD4_e GS Manual Lago Grey

Mine is all wired in, pb78dlrpl. Fits great. I was very surprised, didn't have to mess around to get the sound to work or anything. Just plugged it in with the jumper loom and it all works as expected. Well impressed. And Dash cam wired in now. Only gripe is the rear camera wire is far too short, its a good 2 metres short, unless I just ran it straight through the car!

Post #353767 21st Jul 2018 9:04 pm
View user's profile Send private message View poster's gallery Reply with quote
Scottc3000



Member Since: 13 Jul 2018
Location: Somerset
Posts: 9

United Kingdom 2007 Freelander 2 TD4 HSE Auto Firenze Red

what did you all do to get the xtron to automatically switch to the reversing camera when you go into reverse?

I got this camera
https://www.ebay.co.uk/itm/Xtrons-CAM005-R...Sw2QJa26G5

I have got my camera working fine by connecting the power lead to the reverse light. It comes on when I go into reverse but the xtron does not automatically switch to camera. Do I need to connect a reverse switch cable to the gear knob or something???? It said in the manual that the head unit should just switch when it gets a signal form the camera but no such luck for me

8 core unit

Post #353791 22nd Jul 2018 10:33 am
View user's profile Send private message View poster's gallery Reply with quote
Steven.T



Member Since: 08 Nov 2015
Location: Stockton-On-Tees
Posts: 208

United Kingdom 2009 Freelander 2 TD4_e GS Manual Lago Grey

I haven't got mine wired up yet, be interesting to see how it works. For the dash cam I had to install another APK app file that was on the dashcam to get it to work

Post #353792 22nd Jul 2018 10:42 am
View user's profile Send private message View poster's gallery Reply with quote
Post Reply  Back to top
Page 4 of 5 <12345>
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2018 Futuranet Ltd & Martin Lewis