Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > Technical > DPF?
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
djburns



Member Since: 08 Jan 2012
Location: Pyrenees
Posts: 25

France 2011 Freelander 2 TD4 S Manual Stornoway Grey
DPF?

Hello again, I am having a problem with (I think)the DPF or DPF sensor. (2011 SD4 auto) The car drops in to reduced performance mode from time to time and comes up with code P2454. I can reset the code and it will be fine for a while. I thought I would have fixed it when I replaced all the perished plastic pipes on the sensor but no and it is getting more frequent. I did do a forced regeneration on the motorway with the icarsoft LR11 tool and that took the ash content down to 1-2%. The worst thing that brings it on is a long downhill run with the engine on overrun or sometimes the engine will start with a little hesitation, that also brings it on. One other thing I also get code B100A if thats relevant. Any ideas? Cheers

Post #351091 8th Jun 2018 12:50 pm
View user's profile Send private message View poster's gallery Reply with quote
Yorky Bob



Member Since: 28 Apr 2015
Location: Yorkshire
Posts: 3724

United Kingdom 2013 Freelander 2 TD4 GS Manual Firenze Red

'Reduced Engine Performance' or 'Engine System Fault' message displayed. Torque derate, regeneration locked out (DTC P245400 also logged)

Particulate filter differential pressure sensor voltage below lower limit Sensor failure

Refer to the electrical circuit diagrams and check differential pressure sensor supply circuit for short, open circuit. Install a new sensor as required 51 Series one passed/sold on half restored to a mate to finish years ago.
Lots of Euro Trash
53 Series one low mileage let go foolishly years ago looking at current prices.
Series 2A Safari restored fully while in Saudi Arabia years ago, sold on to a Brit.
FL2 MY10 TD4 GS traded in at 2 years
FL2 MY13 TD4 GS Current

Post #351095 8th Jun 2018 1:14 pm
View user's profile Send private message View poster's gallery Reply with quote
dorsetfreelander



Member Since: 20 Jul 2013
Location: Dorset
Posts: 3098

United Kingdom 2014 Freelander 2 SD4 XS Auto Loire Blue

I had DPF sensor problems on our 2011 model. LR assist diagnosed one out of three exhaust sensors had failed so took it to dealer who put a new sensor in. Five miles later the reduced performance message came up again. They changed another and this seemed to do the trick. They claimed that sometimes you get a misleading message especially if two are throwing Wobblies. 3 x FL1 2 manual + 1 auto no real problems
FL2 S 08 reg 100k no problems
FL2 S 10 reg Gearbox, clutch, throttle body, drive shaft, steering reservoir
FL2 GS 60 reg xfer box, diff and wheel bearings
FL2 GS 11 reg gearbox ,hesitation, exhaust sensors, wiper stalk,
FL2 XS 14 reg SD4 Auto , door lock problem @ 29k

Post #351096 8th Jun 2018 1:27 pm
View user's profile Send private message View poster's gallery Reply with quote
djburns



Member Since: 08 Jan 2012
Location: Pyrenees
Posts: 25

France 2011 Freelander 2 TD4 S Manual Stornoway Grey

Thanks for quick response. Are you suggesting the sensor may well be faulty? Perhaps change it first and check the wiring terminals for voltage, ground etc?

Post #351098 8th Jun 2018 1:37 pm
View user's profile Send private message View poster's gallery Reply with quote
dorsetfreelander



Member Since: 20 Jul 2013
Location: Dorset
Posts: 3098

United Kingdom 2014 Freelander 2 SD4 XS Auto Loire Blue

Have a look at

http://www.freel2.com/forum/topic25109.html 3 x FL1 2 manual + 1 auto no real problems
FL2 S 08 reg 100k no problems
FL2 S 10 reg Gearbox, clutch, throttle body, drive shaft, steering reservoir
FL2 GS 60 reg xfer box, diff and wheel bearings
FL2 GS 11 reg gearbox ,hesitation, exhaust sensors, wiper stalk,
FL2 XS 14 reg SD4 Auto , door lock problem @ 29k

Post #351105 8th Jun 2018 2:54 pm
View user's profile Send private message View poster's gallery Reply with quote
I Like Chips



Member Since: 25 Jun 2017
Location: Cheltenham
Posts: 228

United Kingdom 2011 Freelander 2 SD4 HSE Auto Indus Silver

Check the turbo hoses, it may be a cheap fix.

Post #351126 8th Jun 2018 7:11 pm
View user's profile Send private message View poster's gallery Reply with quote
djburns



Member Since: 08 Jan 2012
Location: Pyrenees
Posts: 25

France 2011 Freelander 2 TD4 S Manual Stornoway Grey

Good idea

Post #351174 9th Jun 2018 5:35 pm
View user's profile Send private message View poster's gallery Reply with quote
djburns



Member Since: 08 Jan 2012
Location: Pyrenees
Posts: 25

France 2011 Freelander 2 TD4 S Manual Stornoway Grey

Just to add to the confusion- I have been wondering about the battery and checked he voltage after sitting overnight, 12.3v. Thought that was a bit low so popped into local garage. Mechanic put on his tester and declared the battery was"kaput!"
I suppose a dodgy battery could interfere with lots of the electrical systems?

Post #351449 13th Jun 2018 6:34 pm
View user's profile Send private message View poster's gallery Reply with quote
Steve D



Member Since: 19 Jan 2013
Location: Essexshire
Posts: 3207

United Kingdom 

A dodgy battery on these cars can give all sorts of fault codes. Fingers crossed. Past: FL2 TD4 HSE Auto
Present: Evoque SD4 Dynamic Lux Auto

Post #351454 13th Jun 2018 7:34 pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2018 Futuranet Ltd & Martin Lewis