Forum-Gallery-Shop-Sponsors

« Advertise on Freel2.com

Home > United Kingdom > RANDOM Cutting Out! Help!
Post Reply  Down to end
Page 1 of 1
Print this entire topic · 
Daggenham_Dave



Member Since: 17 Aug 2017
Location: Stafforsdhire
Posts: 3

United Kingdom 2007 Freelander 2 TD4 GS Manual Indus Silver
RANDOM Cutting Out! Help!

We have a Freelander 2 2.2 TDi. Its started to randomly cut out. Its done it a few times, total shutdown no steering etc. get a warning saying Reduced Engine Performance. Fortunately we have been only going about 20 - 30mph!

We have noticed it is only when its started from cold and it cuts out usually after about 2 miles of running. I know little about cars really but wondered if there might be some sensor tripping or something once the engine reaches a certain temp after warming up.

Any thoughts would be appreciated. Contacted mechanic but waiting on time they can look at it. Is there anything I can check myself?

Thanks in advance guys.....

Post #335868 24th Nov 2017 6:37 pm
View user's profile Send private message View poster's gallery Reply with quote
Largered



Member Since: 10 Jul 2016
Location: UK
Posts: 895

this thread may help.

http://www.freel2.com/forum/topic30511.html

..... and its still active ......

. ________________________________________________________________________
One of a few who uses their Freelander for what it was designed for !
All added items have a purpose and are used regularly.
I spend 6 months of the year on a single trip adventure, both in UK and Europe.
________________________________________________________________________

Post #335870 24th Nov 2017 6:44 pm
View user's profile Send private message View poster's gallery Reply with quote
Daggenham_Dave



Member Since: 17 Aug 2017
Location: Stafforsdhire
Posts: 3

United Kingdom 2007 Freelander 2 TD4 GS Manual Indus Silver

Thanks I'll check it out...

Post #335871 24th Nov 2017 6:45 pm
View user's profile Send private message View poster's gallery Reply with quote
Daggenham_Dave



Member Since: 17 Aug 2017
Location: Stafforsdhire
Posts: 3

United Kingdom 2007 Freelander 2 TD4 GS Manual Indus Silver

Mmmmm looking at threads about my potential problem, I think I'll take off the crankshaft sensor and give it a clean. This seems to have resolved similar issues. Anyone got an instruction thread of where to find the sensor? Looks like its behind the front wheel somewhere.

Post #335879 24th Nov 2017 7:33 pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2006-2018 Futuranet Ltd & Martin Lewis